1С Режим Конфигуратор



         

Перебор записей журнала расчетов


Например, организуем перебор записей с периодом действия в январе.

ЖЗ = СоздатьОбъект("ЖурналРасчетов.Зарплата");

ДатаНач = '01.01.2002';

ДатаКон = '31.01.2002';

ЖЗ.ВыбратьЗаписи(ДатаНач, ДатаКон);

Пока ЖЗ.ПолучитьЗапись()=1 Цикл

......<действия с тек. записью>

КонецЦикла;

А теперь организуем перебор записей, введенных в январе.

ЖЗ = СоздатьОбъект("ЖурналРасчетов.Зарплата");

ДатаНач = '01.01.2002';

ЖЗ. ВыбратьПериод(ДатаНач);

Пока ЖЗ.ПолучитьЗапись()=1 Цикл

.......<действия с тек. записью>

КонецЦикла;

Отличие методов ВыбратьЗаписи и ВыбратьПериод проявляется, если запись введена в другом месяце, но период ее действия лежит в январе. Например, в феврале сотруднику выдают премию за январь. Тогда запись будет введена в феврале (период регистрации), но период ее действия - январь. В первый цикл она попадет, а во второй нет.

Посчитаем все начисления текущего сотрудника за январь:

ВсегоНачислено = 0;

ЖЗ.ВыбратьЗаписиПоОбъекту (ТекСотр, ДатаНач, ДатаКон);

Пока ЖЗ.ПолучитьЗапись()=1 Цикл

....Если ЖЗ.ВидРасч.ВходитВГруппу(ГруппаРасчетов.ВсеНачисления)=1 Тогда

..........ВсегоНачислено = ВсегоНачислено + ЖЗ.Результат;

....КонецЕсли;

КонецЦикла;

Теперь рассчитаем все записи текущего сотрудника, введеные в текущем месяце:

ЖЗ.ВыбратьПериодПоОбъекту (ТекСотр, ДатаНач);

Пока ЖЗ.ПолучитьЗапись()=1 Цикл

........ЖЗ.Рассчитать();

КонецЦикла;

Рассчитаем все записи по документу, независимо от того, в каком расчетном периоде записи порождались:

ЖЗ.ВыбратьЗаписиПоДокументу

(ВыбрДокумент);

Пока ЖЗ.ПолучитьЗапись()=1 Цикл

......ЖЗ.Рассчитать();

КонецЦикла;

Рассчитаем все записи по указанному подразделению. В журнале расчетов указана графа отбора "Подразделение".

ТекПер = ЖЗ.ТекущийПериод();

ЖЗ.ВыбратьПоЗначению ("Подразделение",ВыбрПодразделение, ТекПер, ТекПер);

Пока ЖЗ.ПолучитьЗапись()=1 Цикл

......ЖЗ.Рассчитать();

КонецЦикла;




Содержание  Назад  Вперед