1С Режим Конфигуратор


         

является ли данный счет группой




ЭтоГруппа()


Определяет, является ли данный счет группой (может иметь субсчета) или нет.

Возвращает: 1 - счет является группой; 0 - счет не является группой.
Пример, вывести все синтетические счета:

Счета = СоздатьОбъект("Счет.ОснПлан");

Счета.ВыбратьСчета();

Пока Счета.ПолучитьСчет()=1 Цикл

....Если Счета.ЭтоГруппа()=1 Тогда

..........Сообщить(Счета.Код + " " + Счета.Наименование);

....КонецЕсли;

КонецЦикла;




ИспользоватьРодителя(<Счет>)


Устанавливает / выдает значение родителя (счета вышестоящего уровня), используемого для выборки счетов. Возвращает: значение типа ''Счет'' - текущее значение используемого родителя на момент до исполнения метода.
Пример, вывести все субсчета счета "10 Материалы":

Счета = СоздатьОбъект("Счет.ОснПлан");

Сч10 = СчетПоКоду(10);

Счета.ИспользоватьРодителя(Сч10);

Счета.ВыбратьСчета();

Пока Счета.ПолучитьСчет()=1 Цикл

.....Сообщить(Счета.Код + " " + Счета.Наименование);

КонецЦикла;




Уровень()


Возвращает уровень вложенности текущего счета. (возвращает 1 - для счета верхнего уровня)
Пример, вывести все счета в виде дерева:
Счета = СоздатьОбъект("Счет.ОснПлан");

Счета.ВыбратьСчета();

Пока Счета.ПолучитьСчет()=1 Цикл
отступ = "";

Для ном = 1 По Счета.Уровень() Цикл

....отступ = отступ + " ";

КонецЦикла;

Сообщить(отступ + Счета.Код + " " + Счета.Наименование);
КонецЦикла;




ПринадлежитГруппе(<Счет>)


Определяет, является ли текущий счет субсчетом для счета, указанного в качестве параметра метода. Проверка выполняется по всем вышестоящим уровням счета. Возвращает: 1 - текущий счет является субсчетом для счета, указанного в качестве параметра; 0 - не является.
Пример,

Сч10 = СчетПоКоду("10");

СубСч10 = СчетПоКоду("10.5.1");

Сообщить(СубСч10.ПринадлежитГруппе(Сч10)); //метод вернет 1




Родитель(<НомерУровня>)


Возвращает счет вышестоящего уровня для данного счета. <НомерУровня> - число, которое определяет, какого уровня вышестоящий счет должен быть выдан. Если параметр не указан - выдается непосредственный родитель.

Содержание  Назад  Вперед